Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
All of the email queues on the UBC Mail Relay are clear as of September 29, 2023 at 6:10pm.
Upon further investigation, it was determined that the email delivery delays were caused by a faulty spam engine update that was pushed down to the UBC Mail Relays by the vendor. This update prevented messages from being processed in a timely manner and this resulted in a very large backlog of queued messages. This was acknowledged by the vendor as affecting their clients globally. Although the issue was corrected by the vendor in the early afternoon, UBC was still left with a very large queue of email messages to process, which ended up taking until 6:10pm to deliver.
Please note that emails sent within FASmail did not experience any delivery delays. The delays only affected emails that were sent to or received from external email addresses.
Posted Sep 29, 2023 - 18:48 PDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2023 - 14:09 PDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2023 - 14:08 PDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2023 - 14:05 PDT
Investigating
Some users may be experiencing delays in sending/receiving emails to/from external senders. UBC IT is currently investigating the issue.
Posted Sep 29, 2023 - 13:17 PDT
This incident affected: Email Services (Faculty and Staff Email (FASmail), Mail Relay).