This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


U-Pass Eligibility Issue September 3, 2024, 11:55PT
Incident Report for UBC
Resolved
UBC and TransLink have worked together to resolve this issue. Eligible students who previously had difficulties accessing a Upass should have a UPass loaded onto their Compass card this evening.
Posted 5 months ago. Sep 03, 2024 - 16:30 PDT
Identified
Teams are working to resolve the issue.

The next update is scheduled for 16:00 PT.
Posted 5 months ago. Sep 03, 2024 - 14:30 PDT
Investigating
We have received reports of students having difficulty confirming eligibility for Upass. IT staff are investigating.


Next update at 14:30 PT
Posted 5 months ago. Sep 03, 2024 - 12:02 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan).