This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


FASMail Webmail and Student Webmail issues March 18, 2025 08:40 PT

Incident Report for UBC

Update

2025-03-19 10:00 PT

On March 18, 2025 at approximately 23:45 PT, UBC IT implemented a temporary fix to resolve the login issue affecting access to outlook.office.com. The team continues to work with Microsoft on finding a resolution but access has been restored for now. Please continue to monitor this site if you encounter any further login difficulties.
Posted Mar 19, 2025 - 10:15 PDT

Update

2025-03-18 16:30 PT

Access to outlook.office.com is still unavailable. The team is continuing to work with Microsoft to address this authentication issue. Please continue to use the identified workarounds below to access your email until this issue is resolved.

Workarounds:
1) Access Webmail using the M365 Portal: To access webmail, please log in to https://portal.office.com, click on the Apps menu at the top left of the window and then select Outlook.
2) Download and Set Up Outlook for Mobile on your iPhone or Android device or Outlook on your Desktop:
a. Faculty/Staff: https://it.ubc.ca/microsoft-365/current-projects/exchange-online-migration#ios
b. Students: https://it.ubc.ca/microsoft-365/current-projects/microsoft_foundation_services_project/m365_ubc_student_migration
Posted Mar 18, 2025 - 16:32 PDT

Identified

Access to webmail via outlook.office.com is currently unavailable. However the service is operational with a workaround. To access webmail, please log in to https://portal.office.com, click on the Apps menu at the top left of the window and then select Outlook. Technicians have identified the issue and are working with the vendor to resolve the issue.
Posted Mar 18, 2025 - 09:10 PDT

Investigating

Presently we are experiencing issues with Faculty and Staff Email Webmail. Technicians are investigating.
Posted Mar 18, 2025 - 08:57 PDT
This incident affects: Email Services (Faculty and Staff Email (FASmail)).