Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Our vendor has advised that they are in the process of recovery.
The next update is scheduled for 19:30 PT.
Posted Oct 29, 2025 - 17:37 PDT
Identified
Our vendor has advised that they are in the process of recovery.
The next update is scheduled for 18:00 PT.
Posted Oct 29, 2025 - 14:36 PDT
Investigating
Users may experience issues when visiting the UBC IT Voice services portal (Pinnacle) at billing.it.ubc.ca.
Our vendor has confirmed that they are experiencing a service issue which is resulting in latencies, timeouts and errors loading webpages. They are actively working on recovery of the service.
The next update is scheduled for 14:00 PT.
Posted Oct 29, 2025 - 11:52 PDT
This incident affected: Other (Other - Vancouver).