This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


RESOLVED: UBC External Email Relay Issue January 19, 2022, 07:00 PT
Incident Report for UBC
Resolved
This incident has been resolved as of January 19, 2022, 07:00 PT.
Posted Jan 19, 2022 - 08:39 PST
Investigating
This affects most external incoming and outgoing emails. Internal emails are not affected.
We are currently investigating this issue. Our next update will be by 08:50 PT.
Posted Jan 19, 2022 - 06:51 PST
This incident affected: Email Services (Faculty and Staff Email (FASmail), UBC Student Email, Mail Relay).