This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Student Financial Records
Incident Report for UBC
Resolved
SSC Financials: Service Interruption has been resolved.
Posted Sep 09, 2021 - 09:40 PDT
Update
SSC Financials: Service Interruption - The financial section of the SSC is currently experiencing technical issues. While we work to resolve the issue, you may not be able to view your tuition account or make payments through the SSC.

The tuition payment deadline has been extended to Thursday, September 16.
Posted Sep 08, 2021 - 16:32 PDT
Update
The tuition payment deadline has been extended to Friday, September 10. Administrative deadlines such as proof of permanent residency remain unchanged.
Posted Sep 07, 2021 - 13:42 PDT
Investigating
Please note that we are currently experiencing an issue with the calculation and display of student financial records on the Student Service Centre as well as on the SISC for staff. We are investigating the issue with no current estimated time for a resolution. We suggest returning later this evening to view your financial information.
Posted Sep 07, 2021 - 11:11 PDT
This incident affected: Student Service Centre.