This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


students.ubc.ca site is unavailable January 20, 2022 08:05 PST
Incident Report for UBC
Resolved
The issue has been resolved as of 08:30. students.ubc.ca is now accessible.
Posted Jan 20, 2022 - 08:36 PST
Investigating
The students.ubc.ca website is currently unavailable. Technicians are investigating the issue. There is no estimated time of repair.
Posted Jan 20, 2022 - 08:28 PST
This incident affected: Other (Other - Vancouver).