This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


ServiceNow slow connection over VPN - July 17, 2024
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Aug 01, 2024 - 16:05 PDT
Monitoring
A fix has been implemented and we are currently monitoring the results
Posted Jul 17, 2024 - 16:32 PDT
Investigating
There is currently an issue when connecting to ServiceNow while on the VPN the connection will be very slow.

Our technicians are currently investigating.
Posted Jul 17, 2024 - 16:09 PDT
This incident affected: ServiceNow.