This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


RESOLVED : iPeer Service Outage October 14, 2021 14:55PT – 15:35PT
Incident Report for UBC
Resolved
The UBC iPeer service was temporarily unavailable on October 14, 2021 from 14:55PT – 15:35PT. LT Hub Technicians have worked quickly to resolve the issue and restore service.
Posted Oct 14, 2021 - 16:18 PDT
This incident affected: Other (Other - Vancouver).