This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


network outages ICICS building July 15, 2024 13:48 PT
Incident Report for UBC
Resolved
Network connection has been restored
Posted Jul 18, 2024 - 15:09 PDT
Identified
Network outages due to power issue at the ICICS building CS addition. Network technicians and Building operations are investigating on the issue. There is no estimated time of repair.
Posted Jul 15, 2024 - 14:19 PDT
This incident affected: Network - Campus (Network - Point Grey).