Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
The issue of some sites being inaccessible has been resolved. Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 14:26 PDT
Update
Some sites are inaccessible as a result of this maintenance. UBC IT technicians are investigating the issue.
Posted Sep 11, 2025 - 11:29 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 09:00 PDT
Scheduled
On Thursday, September 11, 2025 from 09:00 PT to 17:00 PT, the UBC SharePoint Software as a Service (SaaS) service will be undergoing maintenance. During this maintenance window, SharePoint sites will be accessible as no interruptions to the service are expected.